Задать вопрос
14 марта, 06:12

Написать программу в паскале: Даны целое n>0 и последовательность из n вещественных чисел, среди которых есть хотя бы одно отрицательное число. Найти величину наибольшего среди отрицательных чисел этой последовательности.

+3
Ответы (1)
  1. 14 марта, 07:22
    0
    Var

    x, max:real;

    n, i:integer;

    begin

    write ('Введите число n: ') ;

    readln (n) ;

    for i:=1 to n do

    begin

    write ('Введите число ', i,': ') ;

    readln (x) ;

    if x<0 then

    begin

    if max=0 then max:=x; / / если это первое отр. число

    if x>max then max:=x

    end

    end;

    writeln ('Наибольшее среди отрицательных: ', max)

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу в паскале: Даны целое n>0 и последовательность из n вещественных чисел, среди которых есть хотя бы одно отрицательное ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы