Задать вопрос
23 декабря, 08:47

Известный исследователь, устав от долгого путешествия по джунгли, лег спать в 10 часов вечера. Перед этим он завел будильник на 12 часов следующего дня. К сожалению, проспать 14 часов ему не удалось, т. к. будильник зазвонил уже через 2 часа. Исследователь забыл, что на будильнике, имеющем 12-ти часовой циферблат, можно задать время до звонка только менее 12 часов. Требуется написать программу, которая определяет, сколько часов успеет проспать исследователь, прежде чем будильник его разбудит.

Входные данные: Два целых числа S и T (1 < S < 24, T < 12) - час, когда исследователь лег спать, и час, на который он установил будильник.

Выходные данные: Целое число - через сколько часов зазвонит будильник.

+3
Ответы (2)
  1. 23 декабря, 09:04
    0
    VB.

    Dim S As Integer ' 1<=S<=24

    Dim T As Integer ' T<=12

    S = InputBox ("S=")

    T = InputBox ("T=")

    Select Case S

    Case Is < = T

    MsgBox (T - S)

    Case Is > T

    If T = 12 Then MsgBox ((T + 12) - S) Else MsgBox (24 - (S - T))

    End Select
  2. 23 декабря, 11:03
    0
    Program gt;

    var k, s, t:integer;

    begin

    read (s, t) ;

    if (s<=12) then begin

    if (s<=t) then k:=t-s;

    if (s>t) then k:=t+12-s;

    end;

    if (s>12) then begin

    if (s<=t+12) then k:=t+12-s;

    if (s>t+12) then k:=24-s+t;

    end;

    writeln (k) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Известный исследователь, устав от долгого путешествия по джунгли, лег спать в 10 часов вечера. Перед этим он завел будильник на 12 часов ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы