Задать вопрос
22 февраля, 23:53

Задача 1

Гарри Поттер узнал, в Хогвартсе номера комнат преподавателей делятся без остатка на все свои цифры, в остальных же комнатах живут ученики. Помогите Гарри определить по известному номеру комнаты N (1 Формат входных данных:

Исходный файл содержит одно число N (1 Формат выходных данных:

В выходной файл вывести, букву "T", если в комнате живет учитель (число N делятся без остатка на все свои цифры кроме нуля) или "P" если ученик (число N не делятся без остатка хотя бы на одну из цифр).

Комментарии: если одна из цифр числа ноль деление на неё не учитывать.

+1
Ответы (1)
  1. 22 февраля, 23:58
    0
    Var

    c, n, k:int64;

    t:boolean;

    begin

    read (n) ;

    c:=n;

    t:=true;

    while (n0) and (t) do

    begin k:=n mod 10; if k0 then

    if c mod k0 then t:=false;

    n:=n div 10;

    end;

    if t=true then writeln ('T') else writeln ('P') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Задача 1 Гарри Поттер узнал, в Хогвартсе номера комнат преподавателей делятся без остатка на все свои цифры, в остальных же комнатах живут ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
Дано натуральнок K от 1 до 180. Написать программу для определения цифры, которая находится в k-той позиции последовательности 10111213 ... 9899. Формат входных данных Файл содержит число k-позиция искомой цифры.
Ответы (1)
Напишите рекурсивную функцию вычисления суммы цифр натурального числа. Формат входных данных На вход ваша программа получает одно натуральное число n (n
Ответы (1)
Условный оператор. Задача 5 Даны три целых числа. Определить, имеется ли среди них хотя бы одна пара равных между собой чисел. Формат входных данных Входной файл содержит три целых числа через пробел.
Ответы (1)
Дано два натуральных числа N и M. Написать программу для определения наименьшего из чисел, составленных из цифр данных чисел. Незначащих нулей в найденном числе быть не должно. Формат входных данных: Входной файл input.
Ответы (1)
Составить программу нахождения для заданного натурального числа N всех делителей, кратных числу C. Формат входных данных Входной файл содержит числа N, C (1≤N, C≤1000). Формат выходных данных Выведите искомые делители.
Ответы (1)