Задать вопрос
4 марта, 23:42

Задача 1

Гарри Поттер узнал, в Хогвартсе номера комнат преподавателей делятся без остатка на все свои цифры, в остальных же комнатах живут ученики. Помогите Гарри определить по известному номеру комнаты N (1 Формат входных данных:

Исходный файл содержит одно число N (1 Формат выходных данных:

В выходной файл вывести, букву "T", если в комнате живет учитель (число N делятся без остатка на все свои цифры кроме нуля) или "P" если ученик (число N не делятся без остатка хотя бы на одну из цифр).

Комментарии: если одна из цифр числа ноль деление на неё не учитывать.

+5
Ответы (1)
  1. 5 марта, 02:47
    0
    Var

    c, n, k:int64;

    t:boolean;

    begin

    read (n) ;

    c:=n;

    t:=true;

    while (n0) and (t) do

    begin k:=n mod 10; if k0 then

    if c mod k0 then t:=false;

    n:=n div 10;

    end;

    if t=true then writeln ('T') else writeln ('P') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Задача 1 Гарри Поттер узнал, в Хогвартсе номера комнат преподавателей делятся без остатка на все свои цифры, в остальных же комнатах живут ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы