Задать вопрос
20 мая, 16:00

Напишите программу на Паскале, которая выводит все простые числа в диапазоне от K до N (2 ≤ K ≤ N ≤ 100000), оканчивающиеся на цифру 3.

Примеры

входные данные

2 30

выходные данные

3 13 23

+5
Ответы (1)
  1. 20 мая, 17:34
    0
    Var

    k, n, x, d: integer;

    begin

    read (k, n) ;

    for x : = k to n do

    if x mod 10 = 3 then

    begin

    d : = 2;

    while x mod d 0 do d : = d + 1;

    if x = d then write (x,' ') ;

    end;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу на Паскале, которая выводит все простые числа в диапазоне от K до N (2 ≤ K ≤ N ≤ 100000), оканчивающиеся на цифру 3. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы