Задать вопрос
17 июня, 07:31

Индивидуальное зачетное задание

Напишите программу, запрашивающую у пользователя время и сообщающую угол поворота минутной и часовой стрелки в градусах и радианах (помните, что тригонометрические функции в Паскале работают с радианами)

+2
Ответы (1)
  1. 17 июня, 08:57
    0
    Var

    n, m:integer;

    r1, r2:real;

    begin

    writeln ('Введите количество часов: ') ;

    readln (n) ;

    writeln ('Введите количество минут: ') ;

    readln (m) ;

    n:=n mod 12;

    r2:=m/60*360;

    r1: = (n*360+r2) / 12;

    writeln ('Угол поворота часовой стрелки ', r1,' градусов или ', r1/180*Pi,' радиан') ;

    writeln ('Угол поворота минутной стрелки ', r2,' градусов или ', r2/180*Pi,' радиан') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Индивидуальное зачетное задание Напишите программу, запрашивающую у пользователя время и сообщающую угол поворота минутной и часовой ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы