Задать вопрос
9 июля, 20:31

Требуется написать программу при выполнении которой с клавиатуры считывается натуральное число N, не превосходящее 10 в девятой степени, и выводится произведение цифр этого числа.

+4
Ответы (1)
  1. 10 июля, 00:22
    0
    uses crt;

    var p, n:integer;

    begin

    p:=1;

    write ('N=') ;

    read (n) ;

    while n>0 do begin

    p:=p * (n mod 10) ;

    n:=n div 10;

    end;

    writeln ('p=', p) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Требуется написать программу при выполнении которой с клавиатуры считывается натуральное число N, не превосходящее 10 в девятой степени, и ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы