Задать вопрос
28 января, 13:00

Составить программу, классифицирующую треугольники по сторонам, если заданы градусные меры трех углов (равносторонний, равнобедренный, разносторонний, прямоугольный).

+3
Ответы (1)
  1. 28 января, 16:58
    0
    Var a, b, c: integer;

    begin

    write ('Введите углы a, b, c >> ') ;

    readln (a, b, c) ;

    if a+b+c = 180 then

    if (a>0) and (b>0) and (c>0) then

    begin

    if (a=b) and (b=c) then writeln ('Равносторонний ') ;

    if ((a=b) and (ac)) or ((b=c) and (ba)) or ((a=c) and (cb)) then writeln ('Равнобедренный ') ;

    if (ab) and (bc) and (ac) then writeln ('Разносторонний ') ;

    if (a=90) or (b=90) or (c=90) then writeln ('Прямоугольный ') ;

    if (a>90) or (b>90) or (c>90) then writeln ('Тупоугольный ') ;

    if (a<=89) and (b<=89) and (c<=89) then writeln ('Остроугольный ')

    end

    else

    writeln ('Углы должны быть больше 0')

    else

    writeln ('Сумма углов не равна 180 градусам') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу, классифицирующую треугольники по сторонам, если заданы градусные меры трех углов (равносторонний, равнобедренный, ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы