Задать вопрос
2 июля, 01:32

Определить среди 3 введенных чисел (a, b, c) количество отрицательных и положительных.

Если больше положительных, то найти минимум из этих 3 чисел, а иначе найти максимум. (нужно нарисовать блок схему и написать программу в паскале)

+2
Ответы (1)
  1. 2 июля, 04:03
    0
    Var a, b, c, m, k:integer;

    begin

    readln (a, b, c) ;

    if a>0 then inc (k) else dec (k) ;

    if b>0 then inc (k) else dec (k) ;

    if c>0 then inc (k) else dec (k) ;

    if k>0 then begin

    if a
    if m>c then m:=c;

    end else begin

    if a>b then m:=a else m:=b;

    if m
    end;

    writeln (m) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Определить среди 3 введенных чисел (a, b, c) количество отрицательных и положительных. Если больше положительных, то найти минимум из этих ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы