Задать вопрос
1 мая, 12:25

Даны три числа a, b, c. Если среди них есть положительные, то найти сумму этих трёх чисел, а иначе найти максимум из трёх.

+4
Ответы (1)
  1. 1 мая, 13:39
    0
    Program df;

    uses crt;

    var a, b, c, max, sum:integer;

    begin

    sum:=0;

    max:=0;

    writeln ('введите числа а, b, c') ;

    readln (a, b, c) ;

    if (a>0) or (b>0) or (c>0) then sum:=a+b+c else if (a>b) and (a>c) then max:=a else if (b>c) then max:=b else max:=c;

    if sum=0 then wrteln ('Числа отрицательные большее из них ', max) else writeln ('сумма чисел ', sum) ; end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Даны три числа a, b, c. Если среди них есть положительные, то найти сумму этих трёх чисел, а иначе найти максимум из трёх. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
Даны три числа. А, В, С. Целые, положительные. Вводятся пользователем, произвольно. Найти максимум и минимум. Вывести максимум и минимум.
Ответы (1)
На с + + с тернарной операцией Даны три целых числа. Требуется определить, превосходит ли максимум этих чисел удвоенную сумму двух других или нет.
Ответы (1)
В саду распустились 19 астр и 21 георгинов. Девочка сорвала 20 цветов. Выберите верные утверждения: Среди этих цветов обязательно есть два георгина Среди этих цветов точно есть 1 георгин Среди этих цветов точно есть 1 астра Среди этих цветов могло
Ответы (1)
Введите с клавиатуры одномерный массив S (K), элементами которого являются положительные и отрицательные числа. Найдите среднее арифметическое значение среди последних 9-ти элементов массива, максимум среди первых 5-ти элементов.
Ответы (1)
Определить среди 3 введенных чисел (a, b, c) количество отрицательных и положительных. Если больше положительных, то найти минимум из этих 3 чисел, а иначе найти максимум. (нужно нарисовать блок схему и написать программу в паскале)
Ответы (1)