Задать вопрос
5 января, 09:14

Файл Date. in файл содержит 3 различных целых чисел, разделенных пробелами. Написать программу, которая укажет, какие из чисел является максимальным, минимальным и какие не является ни минимальным, ни максимальным. Результат отображается на экране и файле date. out.

+1
Ответы (1)
  1. 5 января, 10:14
    0
    Var

    a, b, c, min, max, mid: integer;

    f1, f2: Text;

    begin

    Assign (f1, 'date. in') ;

    Reset (f1) ;

    Read (f1, a, b, c) ;

    Close (f1) ;

    if a > b then begin

    max : = a; min : = b

    end

    else begin

    max : = b; min : = a

    end;

    if max > c then begin

    if min < c then mid : = c

    else begin

    mid : = min; min : = c

    end

    end

    else begin

    mid : = max; max : = c

    end;

    writeln ('Меньшее=', min, ' среднее=', mid, ' большее=', max) ;

    Assign (f2, 'date. out') ;

    Rewrite (f2) ;

    Write (f2, min, ' ', mid, ' ', max) ;

    Close (f2)

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Файл Date. in файл содержит 3 различных целых чисел, разделенных пробелами. Написать программу, которая укажет, какие из чисел является ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
Написать программу, вычисляющую произведение цифр в сумме трех целых числа A, B И C. Входной файл В единственной строке файла содержатся три целых числа A, B И C, разделенных пробелами.
Ответы (1)
Написать программу, вычисляющую сумму цифр в произведении трех целых числа A, B и C. Входной файл В единственной строке файла содержатся три целых числа A, B И C, разделенных пробелами.
Ответы (1)
Дан символьный файл f. Записать в файле g, с сохранением порядка их следования, те символьные данные: a) которым в файле f предшествует буква а б) в след за которыми в файле f идёт буква а
Ответы (1)
Напишите программу, которая получает три числа и выводит количество одинаковых чисел в этой цепочке. Входные данные Входная строка содержит три целых числа, разделённых пробелами.
Ответы (1)
Очень нужна помощь с Паскалем! Напишите программу, которая получает три числа и выводит количество одинаковых чисел в этой цепочке. Входные данные Входная строка содержит три целых числа, разделённых пробелами.
Ответы (1)