Задать вопрос
30 октября, 23:51

Натуральное число называется автоморфным, если оно равно последним числам своего квадрата. Например 25^2 = 625. Напишите программу, которая получает натуральное число N и выводит на экран все автоморфные числа, не превосходящие N.

+1
Ответы (1)
  1. 31 октября, 02:01
    0
    Var

    N, A:integer;

    B:longint;

    k:boolean;

    Begin

    Write ('N = ') ;

    ReadLn (N) ;

    For N: = 1 to N do

    Begin

    k:=true;

    A:=N;

    B:=A*A;

    While A0 do

    Begin

    if (A mod 10 B mod 10) then k:=false;

    A: = A div 10;

    B: = B div 10;

    End;

    if k then Write (N,' ') ;

    End;

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Натуральное число называется автоморфным, если оно равно последним числам своего квадрата. Например 25^2 = 625. Напишите программу, которая ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы