Задать вопрос
25 сентября, 01:47

Составьте программу которая находит сумму цифр трех значного числа на PascalABC

+4
Ответы (2)
  1. 25 сентября, 02:55
    0
    Var

    i, n, s: Integer;

    begin

    write ('Введите трехзначное число ') ;

    read (n) ;

    i:=0;

    while (n0) Do

    begin

    s : = n Mod 10;

    i:=i+s;

    n: = n Div 10;

    end;

    writeLn ('Сумма цифр : ', i)

    end.
  2. 25 сентября, 05:00
    0
    Program n1;

    var a: integer;

    begin

    readln (a) ;

    a:=abs (a) ;

    write ((a div 100) + (a mod 10) + (a mod 100 div 10)) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составьте программу которая находит сумму цифр трех значного числа на PascalABC ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы