Задать вопрос
16 июля, 03:25

1) Сначала суток прошло n секунд, определить: сколько полных часов прошло с начала суток, сколько полных минут прошло с начала текущего часа, сколько полных секунд прошло сначала текущей минуты.

2) Производительность труда при выполнении некоторой работы повысилась на 40%. На сколько процентов сократилось время необходимое для выполнения этой работы.

3) Велосипедист должен попасть в место назначения к определённому сроку. Известно, что если он поедет со скоростью 15 км в час, то приедет на час раньше, а если скорость будет 10 км в час, то опоздает на 1 час. С какой скоростью должен ехать велосипедист, чтобы приехать вовремя?

решите в паскале без описания

+3
Ответы (1)
  1. 16 июля, 04:29
    0
    1)

    var

    sec: LongInt;

    begin

    Write ('sec = ') ;

    Readln (sec) ;

    / / Assert ((n > = 0) and (n < = 24 * 60 * 60), 'Не верный ввод') ;

    WriteLn ('Time: ', sec div 3600, ':', sec div 60 mod 60, ':', sec mod 60) ;

    end.

    2)

    const

    v = 1;

    begin

    WriteLn (100 - 100 * (1 / ((1 + 0.4) * v)) / (1 / v)) ;

    end.

    3)

    а это просто математика

    Система

    S/15 = t-1

    S/10 = t+1

    Отсюда t = 5, s = 60

    v = S/t = 60/5 = 12
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «1) Сначала суток прошло n секунд, определить: сколько полных часов прошло с начала суток, сколько полных минут прошло с начала текущего ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
Идет i-ая секунда суток. Напишите программу, которая по введенной i-ой секунде суток определит, сколько целых часов h, целых минут min и секунд с прошло с начала суток. Например: 13257 секунд = 3 часа 40 минут и 57 секунд.
Ответы (1)
При нажатии клавиши END: Выберите один ответ: курсор перемещается в конец текущей страницы курсор перемещается в конец текущей строки курсор перемещается в конец текста происходит закрытие текущего документа
Ответы (1)
Определить без компьютера, что будет напечатано при выполнении следующих фрагментов: Определите без компьютера, что будет напечатано при выполнении следующих фрагментов программ: 1) a:=100; a:=10*a+1; WriteLn (a) 2) a:=100; a:=-a;
Ответы (1)
Решите в паскале ABC. Известно время полета вылета самолета - HH часов и ММ минут, а также продолжительность полета (НР часов и МР минут). Напечатать время прибытия самолета в аэропорт назначения в виде: самолет прибывает в 12.35.
Ответы (1)
Процесс выполнения операторов присваивания: b:=4; m:=121; z:=b∗m При выполнении оператора b:=4 в ячейку оперативной памяти компьютера с именем b заносится значение ( ...
Ответы (1)