Задать вопрос
22 августа, 06:51

Последовательностью Фибоначчи называется последовательность чисел a0, a1, ..., an, ..., где a0 = 0, a1 = 1, ak = ak-1 + ak-2 (k > 1).

Требуется найти N-е число Фибоначчи.

Примечание. В программе запрещается использовать циклы.

Формат входных данных

На вход программы поступает целое неотрицательное число N (N ≤ 30).

Формат выходных данных

Требуется вывести N-е число Фибоначчи.

Пример

Входные данные

7

Выходные данные

13

+2
Ответы (1)
  1. 22 августа, 06:58
    0
    Var n:integer;

    function Fib (k:integer) : integer;

    begin

    if k=0 then Fib:=0

    else if k=1 then Fib:=1

    else Fib:=Fib (k-1) + Fib (k-2) ;

    end;

    begin

    readln (n) ;

    writeln (Fib (n)) ;

    end.

    Пример:

    10

    55
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Последовательностью Фибоначчи называется последовательность чисел a0, a1, ..., an, ..., где a0 = 0, a1 = 1, ak = ak-1 + ak-2 (k > 1). ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы