Задать вопрос
19 мая, 21:37

Составить программу, заполняющую массив десятью случайными числами и выводящую на экран: 1) максимальное значение; 2) минимальное значение; 3) среднее арифметическое значение.

+3
Ответы (1)
  1. 19 мая, 23:58
    0
    program n1;

    const n=10;

    var

    mas:array[1 ... n] of integer;

    i:integer;

    max, min, sum:integer;

    ar:real;

    begin

    for i:=1 to n do

    begin

    mas[i]: = random (20) - 10;

    write (mas[i],' ') ;

    writeln

    end;

    max:=1;

    for i:=2 to n do

    if mas[i]>mas[max] then

    max:=i;

    writeln;

    writeln ('Максимаьное значение a[', max,'] = ', mas[max]) ;

    min:=1;

    for i:=2 to n do

    if mas[i]
    min:=i;

    writeln;

    writeln (Минимальное значение a[', min,'] = ', mas[min]) ;

    for i:=1 to n do

    sum:=sum+mas[i];

    ar:=sum/n;

    writeln;

    writeln ('Среднее арифметическое = ', ar) ;

    end.

    {Немного нерационально но работает=) }
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу, заполняющую массив десятью случайными числами и выводящую на экран: 1) максимальное значение; 2) минимальное значение; ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы