Задать вопрос
6 мая, 21:12

Пользователь вводит положительное целое число, не превышающее 10^9, нужно написать программу, которая выводит на экран сумму цифр этого числа, меньших 7. если в числе нет цифр, меньших 7, требуется на экран вывести 0

+2
Ответы (2)
  1. 6 мая, 22:19
    0
    Var

    n, sum: integer;

    begin

    read (n) ;

    while n > 0 do

    begin

    if n mod 10 < 7 then

    sum : = sum + n mod 10;

    n : = n div 10

    end;

    writeln (sum) ;

    end.
  2. 7 мая, 01:08
    0
    Program n1;

    var n, k, s:real;

    i:integer;

    begin

    readln (n) ;

    if (n0) then

    begin

    writeln ('число=', n) ;

    if n>=6 then

    begin

    k:=0;

    s:=0;

    while k<7 do

    begin

    s:=s+k;

    k:=k+1;

    end;

    writeln ('сумма цифр=', s) ;

    end else

    writeln ('0') ;

    end;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Пользователь вводит положительное целое число, не превышающее 10^9, нужно написать программу, которая выводит на экран сумму цифр этого ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы