Задать вопрос
3 ноября, 04:40

Помогите составить программу: Сформулировать массив из 12 произвольных чисел. Определить сумму квадратов элементов с чётными индексами. Результат вывести на экран.

+5
Ответы (1)
  1. 3 ноября, 07:00
    0
    var a:array [1 ... 100] of integer;

    i, n, s:integer;

    Begin

    randomize;

    n:=12;

    for i: = 1 to n do begin

    a[i]:=random (n*10) - 10*n div 2;

    write (a[i]:4) ;

    if i mod 10=0 then writeln;

    end;

    for i: = 1 to n do begin

    if i mod 2 = 0 then

    s:=s+a[i];

    end;

    writeln (s) ;

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите составить программу: Сформулировать массив из 12 произвольных чисел. Определить сумму квадратов элементов с чётными индексами. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы