Задать вопрос
20 октября, 00:45

Написать программу, ожидающую от пользователя число (номер года) и выводящую информацию о том, високосный этот год или нет

+4
Ответы (1)
  1. 20 октября, 03:43
    0
    В григорианском календаре високосным является:

    - год, номер которого делится нацело на 400

    - год, номер которого делится на 4, но не делится на 100

    Программа на паскале:

    var n: integer;

    begin

    read (n) ;

    if (n mod 400 = 0) or (n mod 4 = 0) and (n mod 100 > 0)

    then writeln (n, ' год високосный')

    else writeln (n, ' год невисокосный') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу, ожидающую от пользователя число (номер года) и выводящую информацию о том, високосный этот год или нет ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы