Задать вопрос
4 января, 03:25

доброго времени суток.) кто-нибудь может помочь? ибо я совсем не вывожу информатику.

1. Написать программу, которая вводит массив из N целых чисел и выводит на экран элементы с чётными номерами. Протестировать программу на произвольных массивах размерностью 5 и 8 элементов.

2 ... Написать программу, которая вводит массив из N целых чисел и выводит на экран сам массив и сумму всех его элементов. Протестировать программу на следующих массивах:

а) 1 3 4 - 2

б) 0 1 - 2 10 11 12 - 10 - 3

в) 1 1 1 1 - 1 - 1 - 1 - 1

очень прошу-у-у, уделите время, если Вас не затруднит.

+3
Ответы (1)
  1. 4 января, 05:38
    0
    1)

    var a:array [1 ... 100] of integer; объявляем массив

    i, n:byte; объявляем вспомогательную переменную i и переменную n для хранения количества элементов

    begin

    write ('Введите n = ') ; readln (n) ; вводим n

    for i:=1 to n do begin от 1 до n цикл

    write ('a[', i,']=') ;

    readln (a[i]) ; вводим элементы в массив

    end;

    write ('Исходный массив: ') ;

    for i:=1 to n do выводим наш массив полностью

    write (a[i],' ') ;

    writeln;

    write ('Результат: ') ; выводим результат, в данном случае все элементы стоящие на четных местах

    for i:=1 to n do

    if i mod 2 = 0 then write (a[i],' ') ; проверка на четность, мод - это оператор деления по остатку, если индекс делится на 2 без остатка, то выводим элемент

    end.

    2)

    var a:array [1 ... 100] of integer;

    i, n:byte; s:longint; s объявляем для хранения суммы элементов

    begin

    s:=0; обнуляем s

    write ('Введите n = ') ; readln (n) ; тут тоже самое, что и в первой задаче

    for i:=1 to n do begin

    write ('a[', i,']=') ;

    readln (a[i]) ;

    s:=s+a[i]; вот здесь мы складываем каждый элемент массива в переменную s

    end;

    write ('Исходный массив: ') ;

    for i:=1 to n do вывод массива

    write (a[i],' ') ;

    writeln ('Сумма всех элементов массива = ', s) ; вывод суммы

    end.

    Удачи=)
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «доброго времени суток.) кто-нибудь может помочь? ибо я совсем не вывожу информатику. 1. Написать программу, которая вводит массив из N ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы