Задать вопрос
25 сентября, 03:53

напишите программу, которая в последовательности натуральных чисел вычисляет сумму всех чисел кратных 7 и оканчивающихся на 0. Программа получает на вход натуральные числа, количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0 - признак окончания ввода, не входит в последовательность), Количество чисел не превышает 1000. Введенные числа не превышают 30000. Программа должна вывести одно число: сумму всех чисел, кратных 7 и оканчивающихся на 0. Программу надо написать в Pascal

+3
Ответы (1)
  1. 25 сентября, 05:25
    0
    Program n1;

    Uses CRT;

    Var s, i: integer;

    begin

    ClrScr;

    Writeln ('Введите последовательность. Для остановки введите 0 ') ;

    Repeat

    readln (i) ;

    If (i mod 7=0) or (i mod 10=0) then s:=s+i;

    until i=0;

    writeln ('Сумма = ', s) ;

    readln

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «напишите программу, которая в последовательности натуральных чисел вычисляет сумму всех чисел кратных 7 и оканчивающихся на 0. Программа ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы