Задать вопрос
12 сентября, 14:23

2. Составить программу для нахождения цифр четырехзначного числа. Ниже представлен пример диалога. Данные, вводимые пользователем, выделены жирным шрифтом. Введите четырехзначное число 3281 Число тысяч равно 3 Число сотен равно 2 Число десятков равно 8 Число единиц равно 1

+2
Ответы (1)
  1. 12 сентября, 17:41
    0
    Program pr;

    uses crt;

    Var a, x1, x2, x3, x4:integer;

    Begin

    Writeln ('введите 4-х значное число') ;

    readln (a) ;

    x1:=a div 1000;

    x2: = (a mod 1000) div 100;

    x3: = (a mod 100) div 10;

    x4:=a mod 10;

    Writeln (x1) ;

    Writeln (x2) ;

    Writeln (x3) ;

    Writeln (x4) ;

    readln;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «2. Составить программу для нахождения цифр четырехзначного числа. Ниже представлен пример диалога. Данные, вводимые пользователем, выделены ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы