Задать вопрос
13 ноября, 08:48

Помогите написать программу в Паскале ... Дано трехзначное число х найти сумму его цифр, среднее арифметическое и записать число в обратном порядке.

+5
Ответы (1)
  1. 13 ноября, 10:54
    0
    Var

    m, n, n1, n2, n3, n4:integer;

    begin

    Write ('Введите трехзначное натуральное число: ') ;

    Readln (n) ;

    n1: = n mod 10;

    n2: = (n mod 100) div 10;

    n3: = n div 100;

    m:=n1+n2+n3;

    Write ('сумма цифр: ', m) ;

    Write ('среднее арифметическое: ', m/3) ;

    m = 100*n1 + 10*n2 + n3;

    Writeln (' в обратном порядке: ', m)

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите написать программу в Паскале ... Дано трехзначное число х найти сумму его цифр, среднее арифметическое и записать число в обратном ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы