Задать вопрос
16 апреля, 15:06

Составить программу, позволяющую определить, имеет ли число, введённое с клавиатуры целый корень (через оператор if)

+2
Ответы (2)
  1. 16 апреля, 15:33
    0
    Var a:real;

    begin readln (a) ;

    if frac (sqrt (a)) = 0 then write ('Да')

    else write ('Нет') ;

    end.
  2. 16 апреля, 16:57
    0
    Program s;

    var i : integer;

    begin

    readln (i)

    if frac (sqrt (i)) = 0 then write ('Yes.')

    else write ('No.') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу, позволяющую определить, имеет ли число, введённое с клавиатуры целый корень (через оператор if) ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы