Задать вопрос
7 сентября, 00:46

Написать программу для упорядочения чисел a, b, c по возрастанию. Таким образом, что а соответствует наименьшему, b среднему, c наибольшему.

+4
Ответы (1)
  1. 7 сентября, 02:14
    0
    Var a, b, c, t: integer;

    begin

    readln (a, b, c) ;

    if (a > b) then

    begin

    t : = a;

    a : = b;

    b : = t;

    end;

    if (b > c) then

    begin

    t : = b;

    b : = c;

    c : = t;

    end;

    if (a > b) then

    begin

    t : = a;

    a : = b;

    b : = t;

    end;

    writeln (a, ' ', b, ' ', c) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу для упорядочения чисел a, b, c по возрастанию. Таким образом, что а соответствует наименьшему, b среднему, c наибольшему. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы