Задать вопрос
4 июля, 22:27

Смурфетта сшила шапки для своих братьев. На первую шапку она потратила 4 часа, на каждую следующую шапку она тратила на 10 минут меньше. Сколько времени она потратил на N шапок? Составить программу на паскале.

+3
Ответы (1)
  1. 4 июля, 23:34
    0
    Var sum, i, n, mins:integer;

    begin

    read (n) ;

    mins:=4*60;

    sum:=0

    for i:=1 to n do begin

    sum : = sum + mins;

    mins : = mins - 10;

    end;

    writeln ('minut potracheno:', sum) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Смурфетта сшила шапки для своих братьев. На первую шапку она потратила 4 часа, на каждую следующую шапку она тратила на 10 минут меньше. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы