Задать вопрос
29 февраля, 11:21

Составьте программу, которая удаляет лишние пробелы в строке s, оставляя по одному пробелу между словами. Строка s, состоящая из слов, разделенных пробелами, вводится с клавиатуры.

+3
Ответы (1)
  1. 29 февраля, 11:57
    0
    Uses System;

    uses System. Linq; var s: array of string;

    a: string;

    i, x: integer; begin

    readln (a) ;

    s : = a. Split () ;

    for i : = 0 to s. Length - 1 do

    if (s[i]. Length 0) then

    write (s[i] + ' ') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составьте программу, которая удаляет лишние пробелы в строке s, оставляя по одному пробелу между словами. Строка s, состоящая из слов, ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы