Задать вопрос
6 ноября, 10:46

Составить программу, которая формирует массив из 11 случайных целых промежутка [0,15] и выводит на экран сумму и среднее арифметическое элементов массива

+3
Ответы (1)
  1. 6 ноября, 13:24
    0
    Const n=11;

    var a:array[1 ... n] of integer;

    i, s:integer;

    begin

    Randomize;

    for i:=1 to n do

    begin

    a[i]:=random (16) ;

    write (a[i],' ') ;

    end;

    writeln;

    s:=0;

    for i:=1 to n do s:=s+a[i];

    writeln ('s=', s,' sr=', s/n:5:2) ;

    end.

    Пример работы:

    6 12 7 9 3 15 10 10 6 2 8

    s=88 sr = 8.00
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу, которая формирует массив из 11 случайных целых промежутка [0,15] и выводит на экран сумму и среднее арифметическое ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы