Задать вопрос
14 мая, 22:42

Дан целочисленный

двумерный массив 6x 10. Опишите на

русском языке и на языке программирования Паскаль алгоритм вычисления

произведения минимальных элементов из каждой строки. Напечатать значение этого произведения.

Предполагается, что в каждой строке минимальный элемент единственный.

+5
Ответы (1)
  1. 15 мая, 02:38
    0
    Ну в общих чертах проходиться по каждой строке массива, находить минимальный элемент и на него домножать результат.

    uses crt;

    const n=6; m=10;

    var i, j, min, ans:integer;

    a:array[1 ... n, 1 ... m] of integer;

    begin

    ans:=1;

    for i:=1 to n do

    begin

    for j:=1 to m do

    begin

    a[i, j]:=random (1,20) ;

    write (a[i, j]:3) ;

    end;

    writeln;

    end;

    for i:=1 to n do

    begin

    min:=a[i, 1];

    for j:=2 to m do

    if a[i, j]
    min:=a[i, j];

    ans:=ans*min;

    end;

    writeln (ans) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дан целочисленный двумерный массив 6x 10. Опишите на русском языке и на языке программирования Паскаль алгоритм вычисления произведения ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы