Задать вопрос
16 мая, 03:31

Нужна помощь!

1. дан массив состоящий из 5 случайных целых чисел от - 1 до 10. Все его элементы уменьшить на число 20.

2. дан массив состоящий из 8 вещественных чисел. все элементы с четными номерами уменьшить на 1, с нечетными-увеличить на 1.

+3
Ответы (1)
  1. 16 мая, 03:47
    0
    1)

    var

    mas: array [1 ... 5] of integer;

    i:integer;

    begin

    for i:=1 to 5 do

    read (mas[i]) ;

    for i:=1 to 5 do begin

    mas[i]:=mas[i]-20;

    write (mas[i],' ') ;

    end;

    end.

    2)

    var

    mas: array [1 ... 8] of real;

    i:integer;

    begin

    for i:=1 to 8 do

    read (mas[i]) ;

    for i:=1 to 8 do begin

    if i mod 2 = 0 then

    write (mas[i]-1,' ')

    else

    write (mas[i]+1,' ')

    end;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Нужна помощь! 1. дан массив состоящий из 5 случайных целых чисел от - 1 до 10. Все его элементы уменьшить на число 20. 2. дан массив ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
Помогите написать программу в Python. 1) Дан массив, состоящий из целых чисел. Нумерация элементов начинается с 0. Напишите программу, которая выведет элементы массива, номера которых четны (0, 2, 4 ...). 2) Дан массив, состоящий из целых чисел.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
Напишите программу, которая вводит два вещественных числа, a и b (a < b), и выводит через пробел 5 случайных вещественных чисел в полуинтервале [ a, b). Входные данные Входная строка содержит два вещественных числа a и b, разделённых пробелом.
Ответы (1)
1). Дан массив из n чисел (n четное). Написать программу миняющую местами элементы с четными и нечетными номерами 2). Дан массив из n чисел.
Ответы (1)
1.) Вывести на экран одномерный целочисленный массив, состоящий из 10 целых чисел из диапазона [-100; 100] 2.) Задан одномерный целочисленный массив, состоящий из 7 случайных чисел.
Ответы (1)