Задать вопрос
30 мая, 17:34

Электрическая цепь составлена из Электрическая цепь составлена из нескольких сопротивлений. Определите сопротивление между узлами А и Б.

Нужно написать программу в Паскале.

Между А и Б сопротивление

R1, R (общее R2, R3), R4 соединены последовательно, а R2 и R3 параллельно.

Т. е. общее сопротивление равно ...

R=R1 + (R2*R3) / (R2+R3) + R4

на основании этой формулы нужна программа.

+5
Ответы (1)
  1. 30 мая, 19:44
    0
    Var

    r, r1, r2, r3, r4 : real;

    begin

    write ('R1 = ') ; readln (r1) ;

    write ('R2 = ') ; readln (r2) ;

    write ('R3 = ') ; readln (r3) ;

    write ('R4 = ') ; readln (r4) ;

    r : = r1 + (r2 * r3) / (r2 + r3) + r4;

    writeln ('R = ', r) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Электрическая цепь составлена из Электрическая цепь составлена из нескольких сопротивлений. Определите сопротивление между узлами А и Б. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы