Задать вопрос
26 сентября, 10:44

Прошу помогите!

Услуги телефонной сети оплачиваются по следующему правилу: за разговоры до А минут в месяц - В рублей за минуту, а разговоры сверх установленной нормы оплачиваются из расчета С рублей за минуту. Требуется написать программу, вычисляющую плату за пользование телефоном для введенного времени разговоров за месяц.

+1
Ответы (1)
  1. 26 сентября, 10:56
    0
    Var a, d:integer; b, c, p:real;

    begin

    write ('A=') ; readln (a) ;

    write ('B=') ; readln (b) ;

    write ('C=') ; readln (c) ;

    write ('Разговоров за месяц: ') ; readln (d) ;

    if d<=a then p:=b*d else p:=b*a+c * (d-a) ;

    writeln ('Плата за телефон=', p:5:2) ;

    end.

    Пример:

    A=20

    B=1.70

    C=1.90

    Разговоров за месяц: 25

    Плата за телефон=43.50
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Прошу помогите! Услуги телефонной сети оплачиваются по следующему правилу: за разговоры до А минут в месяц - В рублей за минуту, а ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы