Задать вопрос
24 января, 07:28

Написать программу для "Pascal":

Дана целочисленная матрица размерности (NxM). Поменять местами строки с max и min элементами.

+3
Ответы (1)
  1. 24 января, 10:12
    0
    Program n1;

    const maxm = 50;

    maxn = 50;

    var a:array[1 ... maxm, 1 ... maxn] of integer;

    min, max, i, j, n, m, x, maxi, mini:integer;

    begin

    write ('Введите размеры матрицы (N*M) : ') ;

    readln (n, m) ;

    writeln ('Введите матрицу из ', n,' строк и ', m,' столбцов:') ;

    min:=maxint; max:=-maxint-1;

    for i:=1 to n do

    for j:=1 to m do

    begin

    read (a[i, j]) ;

    if a[i, j]>max then begin max:=a[i, j]; maxi:=i; end;

    if a[i, j]
    end;

    for j:=1 to m do

    begin

    x:=a[maxi, j]; a[maxi, j]:=a[mini, j]; a[mini, j]:=x;

    end;

    writeln ('Матрица после преобразования:') ;

    for i:=1 to n do

    begin

    for j:=1 to m do

    write (a[i, j],' ') ;

    writeln;

    end;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу для "Pascal": Дана целочисленная матрица размерности (NxM). Поменять местами строки с max и min элементами. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы