Задать вопрос
27 октября, 07:41

Выведите все натуральные делители числа x в порядке возрастания (включая 1 и само число).

Входные данные

Вводится натуральное число x

Выходные данные

Выведите все делители числа x

Примеры

входные данные

7

выходные данные

1 7

входные данные

21

выходные данные

1 3 7 21

+4
Ответы (1)
  1. 27 октября, 07:57
    0
    Var x, i:integer;

    begin;

    readln (x) ;

    for i:=1 to x do

    if x mod i=0 then writeln (i) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Выведите все натуральные делители числа x в порядке возрастания (включая 1 и само число). Входные данные Вводится натуральное число x ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы