Задать вопрос
24 марта, 16:41

Написать программу подсчитивающую количество цифр целого неотрицательного числа

+4
Ответы (1)
  1. 24 марта, 17:09
    0
    Var a, k:integer;

    begin

    write ('a (>0) = ') ;

    readln (a) ;

    k:=0;

    while a>0 do

    begin

    k:=k+1;

    a:=a div 10;

    end;

    writeln ('k = ', k) ;

    end.

    Пример:

    a (>0) = 180653

    k = 6
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу подсчитивающую количество цифр целого неотрицательного числа ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы