Задать вопрос
6 ноября, 17:02

Написать программу нахождения суммы цифр трехзначного числа (для отрицательных и положительных чисел)

+3
Ответы (1)
  1. 6 ноября, 18:34
    0
    Program zzadani;

    Var n, b, a, c:integer;

    Begin

    Writeln ('Введите трехзначное число') ;

    Readln (n) ;

    a:=n div 100;

    b: = (n div 10) mod 10;

    c: = (n mod 100) mod 10;

    n:=a+b+c;

    Writeln ('Сумма цифр данного числа=', n) ;

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу нахождения суммы цифр трехзначного числа (для отрицательных и положительных чисел) ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы