Задать вопрос
10 марта, 20:33

Найдите наибольший общий делитель двух чисел. Или для цикла (пока), или для цикла (до) в паскале.

+1
Ответы (1)
  1. 10 марта, 21:59
    0
    Var a, b, answer: integer;

    function gcd (m, n: integer) : integer;

    var modulo: integer;

    begin

    modulo : = m mod n;

    if modulo = 0 then gcd : = n

    else gcd : = gcd (n, modulo) end;

    begin

    write ('Введите 2 числа: ') ; readln (a, b) ;

    answer : = gcd (a, b) ;

    writeln ('Наибольший общий делитель: ', answer) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Найдите наибольший общий делитель двух чисел. Или для цикла (пока), или для цикла (до) в паскале. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы