Задать вопрос
30 декабря, 02:10

1) Как, используя функцию random (X), можно получать числа в диапазонах: от 1 до 10, от - 10 до + 10, от 50 до 100?

2) какие значения может принимать целая переменная Y если в программе записано : Y : = 10 + ranodom (5) ?

3) составьте программу заполнения массива из 100 чисел случайными значениями из диапозона от - 20 до 20. подсчитайте в этом массиве колличество положительных и колличество отрицательных значения

+3
Ответы (2)
  1. 30 декабря, 04:13
    0
    1.

    random (10) + 1;

    random (21) - 10;

    random (100) + 50;

    2. y = [10; 14]

    3.

    var

    arr = array[1 ... 100] of real;

    rand : real;

    i : integer;

    p, n:integer;

    begin

    for i : = 1 to 100 do

    begin

    arr[i] : = random (41) - 20;

    i : = i+1;

    end;

    for i : = 1 to 100 do

    begin

    if arr[i] <0 then

    begin

    n : = n+1;

    end;

    if arr[i]>0 then

    begin

    p : = p+1;

    end;

    end;

    writeln ("positives: ", p) ;

    writeln ("negatives: ", n) ;

    readln;

    end.
  2. 30 декабря, 04:17
    0
    1)

    a:=1+Random (10) ;

    a:=-10+Random (20) ;

    a:=50+Random (50) ;

    2)

    10, 11, 12, 13, 14

    3)

    Program zadacha;

    Const n=100;

    Type massiv=Array[1 ... 1000] of Int64;

    Var a:massiv;

    i:Int64;

    Begin

    Randomize;

    For i:=1 to n do

    a[i]:=-20+Random (41) ;

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «1) Как, используя функцию random (X), можно получать числа в диапазонах: от 1 до 10, от - 10 до + 10, от 50 до 100? 2) какие значения может ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы