Задать вопрос
2 августа, 19:37

Напишите программу, которая в последовательности целых чисел находит среднее арифметическое чисел, кратных 9, или сообщает, что таких чисел нет. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 - признак окончания ввода, не является членом последовательности). Количество чисел не превышает 100. Введённые числа по модулю не превышают 300. Программа должна вывести среднее арифметическое чисел, кратных 9, или вывести NO, если таких чисел в последовательности нет.

+3
Ответы (1)
  1. 2 августа, 23:29
    0
    var

    a, i, count, s: integer;

    begin

    repeat

    if (i = 100) then break;

    readln (a) ;

    if (abs (a) > 300) then begin

    writeln ('Число по модулю не может быть > 300.') ;

    continue

    end

    else if (a mod 9 = 0) and (a 0) then begin

    inc (count) ;

    s : = s + a;

    end;

    if (a 0) then inc (i) ;

    until (a = 0) ;

    writeln ('Среднее арифметическое: ', s / count) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу, которая в последовательности целых чисел находит среднее арифметическое чисел, кратных 9, или сообщает, что таких чисел ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы