Задать вопрос
15 мая, 14:12

Дан массив a из n

целых чисел. Требуется сначала вывести элементы, стоящие на четных местах, затем - на нечетных.

Формат входных данных

На первой строке входного файла записано натуральное число n (n≤100) - число элементов в массиве.

На следующей строке через пробел записаны целые числа ai

(∣∣ai∣∣≤103)

- элементы массива.

Формат выходных данных

Требуется в одной строке через пробел вывести элементы массива в заданном порядке.

+2
Ответы (1)
  1. 15 мая, 17:31
    0
    Var

    i, n: integer;

    a: array[1 ... 1000]of integer;

    begin

    readln (n) ;

    for i : = 1 to n do read (a[i]) ;

    writeln;

    for i : = 1 to n do if (i mod 2 = 0) then write (a[i], ' ') ;

    for i : = 1 to n do if (i mod 2 0) then write (a[i], ' ') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дан массив a из n целых чисел. Требуется сначала вывести элементы, стоящие на четных местах, затем - на нечетных. Формат входных данных На ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы