Задать вопрос
11 декабря, 06:54

На паскале

У второклассников очень популярна следующая задача:

101=1

8181515=4

1111112=0

8888888=14

1010101=3

7000007=?

Преподавателю программирования в некоем Центре для одаренных детей так понравилась эта задачка, что он решил именно ее использовать для проверки знаний математики 2-го класса у своих учеников.

Пусть первое число x, а соответствующее ему n

Входные данные

Единственное неотрицательное число x, не превышающее 101001.

Выходные данные

Выведите n.

+3
Ответы (2)
  1. 11 декабря, 07:51
    0
    {тоже как вариант}

    const

    v: array [0 ... 9] of integer = (1,0,0,0,1,0,1,0,2,1) ;

    var

    x, n: integer;

    begin

    read (x) ;

    n : = 0;

    repeat

    n : = n + v[x mod 10];

    x : = x div 10;

    until x = 0;

    write (n)

    end.
  2. 11 декабря, 10:48
    0
    Var

    x: string;

    n, i: integer;

    begin

    readln (x) ;

    for i : = 1 to length (x) do

    case x[i] of

    '0', '4', '6', '9': inc (n) ;

    '8': inc (n, 2) ;

    end;

    writeln (n) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «На паскале У второклассников очень популярна следующая задача: 101=1 8181515=4 1111112=0 8888888=14 1010101=3 7000007=? Преподавателю ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы