Задать вопрос
2 декабря, 07:50

Напишите программу, которая в зависимости от введенного возраста добавляет слова "год", "года" или "лет". Например, при вводе возраста 1, программа сообщает "1 год", при числе 2 - "2 года", при числе 125 - "125 лет".

+2
Ответы (1)
  1. 2 декабря, 10:03
    0
    Var age:integer;

    begin

    readln (age) ;

    if ((age mod 100 > = 10) and (age mod 100 < = 19)) then writeln (age, ' лет')

    else if (age mod 10 = 1) then writeln (age, ' год')

    else if ((age mod 10 > = 2) and (age mod 10 < = 4)) then writeln (age, ' года')

    else writeln (age, ' лет') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу, которая в зависимости от введенного возраста добавляет слова "год", "года" или "лет". Например, при вводе возраста 1, ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы