Задать вопрос
14 января, 10:44

Задача1: Составить программу, которая, если введенное число отрицательное, меняет его на противоположное.

Задача2: Треугольник существует только тогда, когда сумма любых двух его сторон больше третьей.

Дано: a, b, c - стороны предполагаемого треугольника. Требуется сравнить длину каждого отрезка с суммой двух других. Если хотя бы в одном случае отрезок окажется больше суммы двух других, то треугольника с такими сторонами не существует.

+5
Ответы (1)
  1. 14 января, 13:29
    0
    (в паскале) :

    program rwerwe;

    var

    a, b: integer;

    begin

    read (a) ;

    If a<0 then begin b=:a*-1; write (, b,) ; end else write (, a,)

    end.

    pr ...

    var

    a, b, c: real;

    begin

    read (a, b, c)

    If (ABS (a-b)
    else write ('треугольник существует')

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Задача1: Составить программу, которая, если введенное число отрицательное, меняет его на противоположное. Задача2: Треугольник существует ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы