Задать вопрос
20 декабря, 01:27

Проблема та-же но осталось всего 1 задание (остальные 4 сделал сам) прошу помощи вот само задание: Напишите программу которая в последовательности целых чисел определяет их количество и подсчитывает сумму положительных чётных чисел, не превосходящих 256. Программа получает на вход целые числа, количество которых неизвестно, последовательность чисел заканчивается числом 0 (0 - признак окончания ввода, не входит в последовательность).

+5
Ответы (1)
  1. 20 декабря, 02:48
    0
    Var a, n: integer; s:longint;

    begin

    s:=0;

    n:=0;

    readln (a) ;

    while a0 do begin

    n:=n + 1;

    if (a mod 2=0) and (a>0) and (a<=256) then s:=s+a;

    readln (a) ;

    end;

    writeln (n) ;

    writeln (s)

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Проблема та-же но осталось всего 1 задание (остальные 4 сделал сам) прошу помощи вот само задание: Напишите программу которая в ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы