Задать вопрос
19 января, 02:40

Составить программу поиска в целочисленном массиве из 15 элементов двух рядом стоящих элементов, сумма которых больше 10, если таких элементов нет, вывести "NO".

В паскале.

+5
Ответы (1)
  1. 19 января, 04:35
    0
    Const n=15;

    var

    a: array [1 ... n] of integer;

    i:integer;

    p:boolean;

    begin

    p:=true;

    for i: = 1 to n do

    begin

    write ('Введите A[', i,']: ') ;

    readln (a[i]) ;

    end;

    i:=1;

    while p and (i
    begin

    if a[i]+a[i+1]>10 then

    begin

    p:=false;

    writeln;

    writeln (' (A[', i,']=', a[i],') + ((A[', i+1,']=', a[i+1],') > 10') ;

    end;

    inc (i) ;

    end;

    writeln;

    if p then writeln ('NO') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу поиска в целочисленном массиве из 15 элементов двух рядом стоящих элементов, сумма которых больше 10, если таких ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы