Задать вопрос
6 февраля, 10:19

Помогите написать программу которая из 20 чисел находит максимальное трехзначное число, не кратное 9. если таких чисел нет, писать "нет"

const

N=20;

var

a:array [1 ... N] of integer;

i, j, max:integer;

begin

for i: = 1 to N do

readln (a[i]) ;

max:=99;

j:=a[i];

for i: = 1 to N do

if (j>99) and (j<999) and (j mod 9 0) and (j>max) then max:=j;

if max>99 then writeln (max) else writeln ('no') ;

readln;

end.

программа проверяет только последнее число, а не все 20. где ошибка?

+2
Ответы (2)
  1. 6 февраля, 11:19
    0
    const

    N=20;

    var

    a:array [1 ... N] of integer;

    i, j, max, k:integer;

    begin

    max:=99;

    for i: = 1 to N do

    begin

    readln (a[i]) ;

    j:=a[i];

    for k: = 1 to N do

    begin

    if (j>99) and (j<999) and (j mod 9 0) and (j>max) then max:=j;

    end;

    end;

    if max>99 then writeln (max) else writeln ('no') ;

    end.
  2. 6 февраля, 11:47
    0
    Я бы написал легче, но тут ошибка в цикле, после объявление цикла начни begin, а после if max>99 then ... end; Именно ";"
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите написать программу которая из 20 чисел находит максимальное трехзначное число, не кратное 9. если таких чисел нет, писать "нет" ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы