Задать вопрос
26 октября, 09:35

Известен рост учащихся класса. Рост мальчиков задан отрицательными числами. Определите количество девочек в классе.

Всё делать при помощи массива

+4
Ответы (1)
  1. 26 октября, 13:00
    0
    Const n=10;

    var a: array[1 ... n] of integer;

    i, k: integer;

    begin

    writeln ('Исходный массив:') ;

    for i:=1 to n do begin

    write ('a[', i,']=') ;

    readln (a[i]) ;

    end;

    writeln;

    k:=0;

    for i:=1 to n do

    if a[i]>0 then k:=k+1;

    writeln ('k = ', k) ;

    end.

    Пример:

    Исходный массив:

    a[1]=168

    a[2]=156

    a[3]=155

    a[4]=-176

    a[5]=154

    a[6]=-175

    a[7]=-173

    a[8]=174

    a[9]=164

    a[10]=-170

    k = 6
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Известен рост учащихся класса. Рост мальчиков задан отрицательными числами. Определите количество девочек в классе. Всё делать при помощи ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы