Задать вопрос
10 августа, 00:56

Напишите программу в паскале: найти сумму членов арифметической прогрессии, если известны ее первый член, разность и число членов прогрессии.

+1
Ответы (2)
  1. 10 августа, 03:15
    0
    Var a, b, c, k:real;

    begin;

    write ('Введите первое число прогрессии:') ;

    readln (a) ;

    write ('Введите разность прогрессии:') ;

    readln (b) ;

    write ('Введите число членов прогрессии:') ;

    readln (c) ;

    k: = ((2*a+b * (c-1)) / 2) * c;

    writeln (k) ;

    end.
  2. 10 августа, 04:34
    0
    Program SAP;

    var

    S, d: integer;

    i, N: byte;

    a: array[1 ... 255] of integer;

    begin

    write ('Введите первый член арифметической прогрессии: ') ;

    readln (a[1]) ;

    write ('Введите разность арифметической прогрессии: ') ;

    readln (d) ;

    write ('Введите количество членов арифметической прогрессии: ') ;

    readln (N) ;

    for i: = 2 to N do begin

    a[i]: = a[1] + (i - 1) * d;

    S: = S + a[i]

    end;

    writeln ('Сумма членов арифметической прогрессии: ', S) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу в паскале: найти сумму членов арифметической прогрессии, если известны ее первый член, разность и число членов ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы