Задать вопрос
9 мая, 17:00

составить программу в паскале для поиска простых чисел в числовом промежутке от 1 до 100

+4
Ответы (1)
  1. 9 мая, 20:40
    0
    program abc;

    var

    i, j:integer;

    pr:boolean;

    begin

    writeln ('Простые числа в диапазоне от 1 до 100: ') ;

    for i : = 2 to 100 do

    begin

    pr : = true;

    for j : = 2 to i div 2 do

    if i mod j = 0 then

    begin

    pr : = false;

    break;

    end;

    if pr then

    write (i, ' ') ;

    end;

    writeln;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «составить программу в паскале для поиска простых чисел в числовом промежутке от 1 до 100 ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы