Задать вопрос
29 июля, 18:51

Написать программу в PascalABC!

Число в двоичной системе счисления, введенное

пользователем программы, преобразовать в десятичное число.

+3
Ответы (1)
  1. 29 июля, 21:25
    0
    Var a:string;

    i, a1, ar:integer; b:real;

    begin

    readln (a) ;

    b:=0;

    for i:=1 to length (a) do

    begin

    val (a[length (a) - i+1], a1, ar) ;

    b:=b+a1*exp ((i-1) * ln (2)) ;

    end;

    writeln ('b=', b) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу в PascalABC! Число в двоичной системе счисления, введенное пользователем программы, преобразовать в десятичное число. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы